<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
   <head profile="http://gmpg.org/xfn/11">
      <meta name="description" content="Ethiopian news: ethioforum.org EMF to discuss. daily Ethiopian news, discussion forum, music, video, audio and sport news from Ethiopia" />
      <meta name="keywords" content="ethiopian media forum, ethiopia media,ethiopian news,ethiopian news, ethiopia, EMF, addis ababa, ethiopian,ethiopians, ethio, zena, amharic news, amharic articles, amharic discussions" />
      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
      <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
      <title>  Ethiopian Canadian Lawyer Teklemicheal, reflect on Canadian immigration law | Ethiopian Media Forum (EMF)</title>
      <link rel="stylesheet" type="text/css" media="all" href="http://ethioforum.org/wp-content/themes/wpnewspaper/style.css" />
      <style type="text/css">
	  .pluginCountTextConnected {display: inherit!important;} 
	  .pink {font-size:11px;color:#2d2d2d;} 
	  .red {font-style:italic;font-size:12px;color:#4EA10F;}
	  table.links {font-family: Verdana;font-weight: normal;font-size: 12px;background-color:#000000; color:#FFFFFF;border: 1px #6699CC solid;border-collapse: collapse;border-spacing: 0px; }
	  table.links th {border-bottom: 1px solid #6699CC;border-left: 1px solid #6699CC;text-align: center;text-indent: 2px;font-family: Verdana;font-weight: bold;font-size: 12px;background-color:#000000; color:#FFFFFF;}
	  table.links td {border-bottom: 1px solid #9CF;border-top: 0px;border-left: 1px solid #9CF;border-right: 0px;text-align: left;text-indent: 4px;font-family: Verdana, sans-serif, Arial;font-weight: normal;font-size: 12px;background-color:#000000; color:#FFFFFF;}
	  table.links a:link, table a:visited, table a:active { color: #fff; text-decoration: none; }table.links a:hover { color: #000; text-decoration: underline; background-color : #fff;} 
	  /*]]>*/
      </style>
   
   <script type="text/javascript">
	function quickLink(links) {
	  popup = links.options[links.selectedIndex].value;
	  if (popup == '#') {
		return false;
	  } else {
		window.open(popup, 'newWin');
	  }
	}
	// Copyright (C) 2005-2008 Ilya S. Lyubinskiy. All rights reserved.
	// Technical support: http://www.php-development.ru/
	//
	// YOU MAY NOT
	// (1) Remove or modify this copyright notice.
	// (2) Re-distribute this code or any part of it.
	//     Instead, you may link to the homepage of this code:
	//     http://www.php-development.ru/javascripts/dropdown.php
	//
	// YOU MAY
	// (1) Use this code on your website.
	// (2) Use this code as part of another product.
	//
	// NO WARRANTY
	// This code is provided "as is" without warranty of any kind.
	// You expressly acknowledge and agree that use of this code is at your own risk.
	// ***** Popup Control *********************************************************
	// ***** at_show_aux *****
	function at_show_aux(parent, child) {
	  var p = document.getElementById(parent);
	  var c = document.getElementById(child);
	  var top = (c["at_position"] == "y") ? p.offsetHeight + 2 : 0;
	  var left = (c["at_position"] == "x") ? p.offsetWidth + 2 : 0;
	  for (; p; p = p.offsetParent) {
		top += p.offsetTop;
		left += p.offsetLeft;
	  }
	  c.style.position = "absolute";
	  c.style.top = top + 'px';
	  c.style.left = left + 'px';
	  c.style.visibility = "visible";
	}
	// ***** at_show *****
	function at_show() {
	  var p = document.getElementById(this["at_parent"]);
	  var c = document.getElementById(this["at_child"]);
	  at_show_aux(p.id, c.id);
	  clearTimeout(c["at_timeout"]);
	}
	// ***** at_hide *****
	function at_hide() {
	  var p = document.getElementById(this["at_parent"]);
	  var c = document.getElementById(this["at_child"]);
	  c["at_timeout"] = setTimeout("document.getElementById('" + c.id + "').style.visibility = 'hidden'", 333);
	}
	// ***** at_click *****
	function at_click() {
	  var p = document.getElementById(this["at_parent"]);
	  var c = document.getElementById(this["at_child"]);
	  if (c.style.visibility != "visible") at_show_aux(p.id, c.id);
	  else c.style.visibility = "hidden";
	  return false;
	}
	// ***** at_attach *****
	// PARAMETERS:
	// parent   - id of the parent html element
	// child    - id of the child  html element that should be droped down
	// showtype - "click" = drop down child html element on mouse click
	//            "hover" = drop down child html element on mouse over
	// position - "x" = display the child html element to the right
	//            "y" = display the child html element below
	// cursor   - omit to use default cursor or specify CSS cursor name
	function at_attach(parent, child, showtype, position, cursor) {
	  var p = document.getElementById(parent);
	  var c = document.getElementById(child);
	  p["at_parent"] = p.id;
	  c["at_parent"] = p.id;
	  p["at_child"] = c.id;
	  c["at_child"] = c.id;
	  p["at_position"] = position;
	  c["at_position"] = position;
	  c.style.position = "absolute";
	  c.style.visibility = "hidden";
	  if (cursor != undefined) p.style.cursor = cursor;
	  switch (showtype) {
		case "click":
		  p.onclick = at_click;
		  p.onmouseout = at_hide;
		  c.onmouseover = at_show;
		  c.onmouseout = at_hide;
		  break;
		case "hover":
		  p.onmouseover = at_show;
		  p.onmouseout = at_hide;
		  c.onmouseover = at_show;
		  c.onmouseout = at_hide;
		  break;
	  }
	}
	 </script>

	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://ethioforum.org/feed/" />	
	<link rel="pingback" href="http://ethioforum.org/xmlrpc.php" />
	<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Ethiopian Media Forum (EMF) &raquo; Feed" href="http://ethioforum.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ethiopian Media Forum (EMF) &raquo; Comments Feed" href="http://ethioforum.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ethiopian Media Forum (EMF) &raquo; Ethiopian Canadian Lawyer Teklemicheal, reflect on Canadian immigration law Comments Feed" href="http://ethioforum.org/ethiopian-canadian-lawyer-teklemicheal-reflect-on-canadian-immigration-law/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/ethioforum.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='hupso_css-css'  href='http://ethioforum.org/wp-content/plugins/hupso-share-buttons-for-twitter-facebook-google/style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='fancyboxcss-css'  href='http://ethioforum.org/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.fancybox-1.3.4.css?ver=4.8.3' type='text/css' media='all' />
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://ethioforum.org/wp-content/themes/wpnewspaper/inc/js/jquery.cycle.all.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://ethioforum.org/wp-content/themes/wpnewspaper/inc/js/slides.min.jquery.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://ethioforum.org/wp-content/themes/wpnewspaper/inc/js/jquery.tools.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://ethioforum.org/wp-content/themes/wpnewspaper/inc/js/flowplayer/flowplayer-3.2.6.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://ethioforum.org/wp-content/themes/wpnewspaper/inc/js/superfish-1.4.8.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://apis.google.com/js/plusone.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://ethioforum.org/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.fancybox-1.3.4.pack.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://ethioforum.org/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.mousewheel-3.0.4.pack.js?ver=4.8.3'></script>
<link rel='https://api.w.org/' href='http://ethioforum.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ethioforum.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ethioforum.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='What happened in Zimbabwe?' href='http://ethioforum.org/what-happened-in-zimbabwe/' />
<link rel='next' title='Ethiopians follow Zimbabwe events with Mengistu in mind' href='http://ethioforum.org/ethiopians-follow-zimbabwe-events-with-mengistu-in-mind/' />
<meta name="generator" content="WordPress 4.8.3" />
<link rel="canonical" href="http://ethioforum.org/ethiopian-canadian-lawyer-teklemicheal-reflect-on-canadian-immigration-law/" />
<link rel='shortlink' href='http://ethioforum.org/?p=173780' />
<link rel="alternate" type="application/json+oembed" href="http://ethioforum.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fethioforum.org%2Fethiopian-canadian-lawyer-teklemicheal-reflect-on-canadian-immigration-law%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://ethioforum.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fethioforum.org%2Fethiopian-canadian-lawyer-teklemicheal-reflect-on-canadian-immigration-law%2F&#038;format=xml" />
<script type="text/javascript" src="http://ethioforum.org/wp-content/plugins/audio-player/assets/audio-player.js?ver=2.0.4.6"></script>
<script type="text/javascript">AudioPlayer.setup("http://ethioforum.org/wp-content/plugins/audio-player/assets/player.swf?ver=2.0.4.6", {width:"290",animation:"no",encode:"yes",initialvolume:"60",remaining:"yes",noinfo:"yes",buffer:"5",checkpolicy:"no",rtl:"yes",bg:"f8f8f8",text:"666666",leftbg:"eeeeee",lefticon:"666666",volslider:"666666",voltrack:"FFFFFF",rightbg:"cccccc",rightbghover:"999999",righticon:"666666",righticonhover:"ffffff",track:"FFFFFF",loader:"9FFFB8",border:"666666",tracker:"DDDDDD",skip:"666666",pagebg:"FFFFFF",transparentpagebg:"yes"});</script>
<link href="http://ethioforum.org/wp-content/themes/wpnewspaper/styles/red.css" rel="stylesheet" type="text/css" />

	<script type='text/javascript'>
	(function($) {
		$(document).ready(function() { 
			
			$('a[href=#top]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });
			
			$("a[rel=gab_gallery]").fancybox({
				'transitionIn'		: 'none',
				'transitionOut'		: 'none',
				'titlePosition' 	: 'over',
				'titleFormat'       : function(title, currentArray, currentIndex, currentOpts) {
					return '<span id="fancybox-title-over">' + title /* + ' ('+(currentIndex + 1) + ' / ' + currentArray.length + ')' */ +'</span>';
				}
			});				
				
			$('#featured-slider .fea-slides').cycle({ 
				pauseOnPagerHover: 1,
				prev:   '.fea_prev',
				next:   '.fea_next',
				pauseOnPagerHover: 1,
				fx:     'fade',
				timeout: '5',
				speed: '1',
				pager:  '#featured-nav', 
				pagerAnchorBuilder: function(idx, slide) { 
					// return selector string for existing anchor 
					return '#featured-nav li:eq(' + idx + ') a'; 
				} 
			});

			$('#video-slider .fea-slides').cycle({ 
				pauseOnPagerHover: 1,
				prev:   '.vid_prev',
				next:   '.vid_next',
				pager:  '#vid-nav', 
				fx:     'fade',
				timeout: 0
			});
			
			$('#mid-slider .fea-slides').cycle({ 
				fx:     'fade', 
				timeout: 0,
				prev:   '.media_prev',
				next:   '.media_next',
				pauseOnPagerHover: 1,
				pager:  '#mid-slider-pagination', 
				pagerAnchorBuilder: function(idx, slide) { 
					// return selector string for existing anchor 
					return '#mid-slider-pagination li:eq(' + idx + ') a'; 
				} 
			});					

			$('#slides').slides({
								play: 5000,
				pause: 2500,
				hoverPause: true,
								autoHeight: true
			});
			
			$(".show").fancybox({  'titleShow': 'false','transitionIn': 'fade','transitionOut': 'fade'});
			$(".iframe").fancybox({	'width'	: '75%','height' : '75%','autoScale': false,'transitionIn': 'none','transitionOut': 'none','type': 'iframe'});
			$("ul.tabs").tabs("div.panes > div");
			$("ul.sc_tabs").tabs("div.sc_tabs-content > div");
		});
	})(jQuery);
	</script>
<link rel="shortcut icon" href="http://ethioforum.org/wp-content/uploads/2012/03/favicon.ico"/>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38368434-1', 'ethioforum.org');
  ga('send', 'pageview');

</script>
	
		
		<!--[if lte IE 8]>
		<style type="text/css" media="screen">
			#gab_gallery .apple_overlay {border:1px solid #aaa;}
            </style>
            	<![endif]-->	
<!--visitorTracker-->
<script language="javascript" type="text/javascript" src="http://ethioforum.org/amharic_handler/translate.js"></script>
<style type="text/css">
@font-face { font-family: Nyala; src: url("http://ethioforum.org/amharic_handler/nyala.eot") }
@font-face { font-family: nyala; src: url("http://ethioforum.org/amharic_handler/nyala.ttf")}
/*body{ font-family:'GF Zemen', 'GF Zemen Unicode', 'Visual Geez Unicode' Nyala, nyala}*/
</style>

</head>
<body class="post-template-default single single-post postid-173780 single-format-standard">
      <div class="wrapper">
     
		<div id="masthead">
		<ul class="mastheadnav dropdown">

			                <li>     </li>
               	<li><a id="src_parent">QUICK LINKS|</a></li>
                <li><a href="http://ethioforum.org/contact-us/">CONTACT|</a></li>
                <li><a href="http://ethioforum.org/rss-2/" target="_blank">Headlines (RSS)</a></li>  
			
		</ul>

		<div class="hide">
			<div id="sconnected"> 
				<div id="gab_social_widget-3" class="widget gab_social_widget"><div class="widgetinner"><h3 class="widgettitle">Socialize</h3>
<a target="_blank" class="facebook" href="http://www.facebook.com/ethioMediaForum" rel="nofollow">Facebook</a><a target="_blank" class="twitter" href="http://twitter.com/#!/EthioMediaForum" rel="nofollow">Twitter</a><a target="_blank" class="feed" href="http://ethioforum.org/?feed=rss2" rel="nofollow">RSS Feed</a><a target="_blank" class="youtube" href="http://www.youtube.com/ethiomediaForum" rel="nofollow">Youtube</a><div class="clear"></div></div></div>
    	</div>

		</div>

		<div id="search">
	<form class="gab_search_style1" action="http://ethioforum.org/">
	<fieldset>
		<input type="text" id="s" name="s" value="Search in site..." onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;"/>
		<input type="image" class="submit_style1" src="http://ethioforum.org/wp-content/themes/wpnewspaper/framework/images/search.png" alt="Search in site..." value="" /> 
	</fieldset>
</form>
		</div><!-- /search -->
		<div class="clear"></div>

	</div><!-- /masthead -->


	<div id="header">
					<div class="logo" style="float:left;margin:0;padding:5px 0px 5px 0px;">	

									<h1>
						<a href="http://ethioforum.org/" title="Latest Ethiopian News, Analysis and Discussion Forum">
							<img src="http://ethioforum.org/wp-content/uploads/2012/03/emf_logo_red.jpg" alt="Ethiopian Media Forum (EMF)" title="Ethiopian Media Forum (EMF)"/>
						</a>
					</h1>
							</div><!-- logo -->
			<div class="banner">
				<script type="text/javascript"><!--
google_ad_client = "ca-pub-8421858419192011";
/* emf 480 banner */
google_ad_slot = "6661432729";
google_ad_width = 468;
google_ad_height = 60;
//-->
</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>			</div>
			<div class="clear"></div>
			</div><!-- /header -->
	<div id="mainmenu">
		<ul class="mainnav dropdown">
						   	<li class="first"><a href="http://ethioforum.org/" title="Latest Ethiopian News, Analysis and Discussion Forum">Home</a></li>

					<li class="cat-item cat-item-10"><a href="http://ethioforum.org/category/featured/" >FEATURED</a>
</li>
	<li class="cat-item cat-item-7"><a href="http://ethioforum.org/category/news/" >NEWS</a>
</li>
	<li class="cat-item cat-item-12"><a href="http://ethioforum.org/category/views/" >VIEWS</a>
</li>
				
       <li style="float:right;border-left: 1px solid rgb(158, 144, 144);border-right: 1px solid rgb(158, 144, 144);"> <a href="http://ethioforum.org/amharic/">  
        <img src="http://ethioforum.org/wp-content/uploads/2014/05/to_amharic.gif" alt=" ወደ አማርኛ ገጽ " border="0"/>   
        <img src="http://ethioforum.org/wp-content/uploads/2012/11/New_Icon.gif" border="0"/></a>
        </li>
		</ul>
		<div class="clear"></div>
	</div><!-- /mainmenu -->
		
	<div id="submenu">
		<ul class="subnav dropdown">
    	<div class="ad728">
	<script type="text/javascript"><!--
google_ad_client = "ca-pub-8421858419192011";
/* EMF LEAD */
google_ad_slot = "9468656577";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div>
	
		</ul>
		<div class="clear"></div>
        </div><!-- /submenu -->
     	

      <div id="src_child" style="float:right;z-index:90;position:absolute; border:1px solid #333333; background-color:#ccc; font-size:14px; padding:5px;">
         <table class="links">
            <tr>
               <th colspan="2">News sites</th>
               <th>Audiovisuals</th>
               <th>Advocacy groups</th>
               <th>Political Org</th>
               <th>Sport/culture</th>
            </tr>
            <tr>
               <td>&raquo; <a href="http://ethioforum.org/amharic/"> አማርኛ</a></td>
               <td>&raquo; <a target="_blank" href="http://abugidainfo.com/"> Abugida</a></td>
               <td>&raquo; <a target="_blank" href="http://addisdimts.com/"> Addisdimts</a></td>
               <td>&raquo; <a target="_blank" href="http://www.solidaritymovement.org"> SMNE </a></td>
               <td>&raquo; <a target="_blank" href="http://www.andinet.org/"> Andinet/UDJ </a></td>
               <td>&raquo; <a target="_blank" href="http://www.ethiosports.com/"> Ethiosport</a></td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://ethioforum.org/"> Addis Voice</a></td>
               <td>&raquo; <a target="_blank" href="http://www.ethioreference.com/"> Ethioreference</a></td>
               <td>&raquo; <a target="_blank" href="http://www.dw-world.de/dw/0,,611,00.html"> DW Amharic</a></td>
               <td>&raquo; <a target="_blank" href="http://www.ehrco.org"> EHRCO</a></td>
               <td>
                  &raquo; 
                  <a target="_blank" href="http://www.andinetusa.org/">
                     Andinet/USA </a>
               </td>
               <td>&raquo; <a target="_blank" href="http://www.esfna.net/"> ESFNA </a></td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://www.cyberethiopia.com/"> Cyberethiopia</a></td>
               <td>&raquo; <a target="_blank" href="http://www.ecadforum.com/"> EcadForum </a></td>
               <td>&raquo; <a target="_blank" href="http://www.voanews.com/horn/amharic_audio.cfm"> VOA Amharic</a></td>
               <td>&raquo; <a target="_blank" href="http://advocacyforethiopia.org"> Advocacy Ethiopia</a></td>
               <td>&raquo; <a target="_blank" href="http://www.eprp.com/"> EPRP </a> </td>
               <td>&raquo; <a target="_blank" href="http://www.librogk.com"> Libro </a></td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://ethiopianreview.com/"> ER</a></td>
               <td>&raquo; <a target="_blank" href="http://ethiopianege.com/"> Ethiopianege</a></td>
               <td>&raquo; <a target="_blank" href="http://ethsat.com/"> ESAT </a></td>
               <td>&raquo; <a target="_blank" href="http://www.masreja.com/"> masreja.com </a></td>
               <td>&raquo; <a target="_blank" href="http://eprp-ihapa.com"> EPRP D</a></td>
               <td>&raquo; <a target="_blank" href="http://athleticsethiopia.org.et/"> Athletics Ethiopia</a></td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://www.ethiofreedom.com/"> Ethiofreedom</a> </td>
               <td>&raquo; <a target="_blank" href="http://ethiopiazare.com/"> EthiopiaZare</a></td>
               <td>&raquo; <a target="_blank" href="http://ethiotube.net/"> Ethiotube </a></td>
               <td>&raquo; <a target="_blank" href="http://www.nesglobal.org"> NES Global</a></td>
               <td>&raquo; <a target="_blank" href="http://www.ginbot7.org/"> Ginbot 7</a></td>
               <td>&raquo; <a target="_blank" href="http://www.addisculture.com"> AddisCulture </a></td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://nazret.com/"> Nazret </a></td>
               <td>&raquo; <a target="_blank" href="http://www.quatero.net/"> Quatero </a></td>
               <td>&raquo; <a target="_blank" href="http://tenaadam.com/"> Tena'dam</a></td>
               <td>&raquo; <a target="_blank" href="http://www.ethiopiangasha.org/"> Gasha </a></td>
               <td>&raquo; <a target="_blank" href="http://www.ethioshengo.org/"> Shengo</a></td>
               <td><span style="font-size:14px; font-style:oblique; font-weight:bold; color: #FFCC00">Music sites</span></td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://ethiomedia.com/"> EthioMedia</a></td>
               <td><span style="font-size:14px; font-style:oblique; font-weight:bold; color: #FFCC00">Local src</span> </td>
               <td>&raquo; <a target="_blank" href="http://diretube.com/"> Diretube </a></td>
               <td>&raquo; <a target="_blank" href="http://www.amnesty.org/"> Amnesty </a> </td>
               <td>&raquo; <a target="_blank" href="http://onlf.org/"> ONLF</a></td>
               <td>&raquo; </td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://www.zehabesha.com"> Zehabesha</a></td>
               <td>&raquo; <a target="_blank" href="http://www.addisfortune.com"> Addisfortune</a> </td>
               <td>&raquo; <a target="_blank" href="http://www.ethiopianege.com"> Ethiopianege</a></td>
               <td><span style="font-size:14px; font-style:oblique; font-weight:bold; color: #FFCC00">Blogs</span></td>
               <td>&raquo; <a target="_blank" href="http://www.timret.org/"> Timret</a> </td>
               <td>&raquo; <a target="_blank" href="http://lucyzare.com/"> Lucyzare </a></td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://tadias.com/"> Tadias </a></td>
               <td>&raquo; <a target="_blank" href="http://www.capitalethiopia.com"> Capital</a> </td>
               <td>&raquo; <a target="_blank" href="http://lucyzare.com/"> Lucyzare </a></td>
               <td>&raquo; <a target="_blank" href="http://www.ethioreference.com"> Ethioreference </a></td>
               <td><span style="font-size:14px; font-style:oblique; font-weight:bold; color: #FFCC00">EPRDF src</span> </td>
               <td>&raquo; <a target="_blank" href="http://www.harartubes.com/"> harartubes </a></td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://www.africaim.com"> Africa media </a></td>
               <td>&raquo; <a target="_blank" href="http://www.ethiosun.com/"> Ethiosun </a> </td>
               <td>&raquo; <a target="_blank" href="http://www.goolgule.com/">Goolgule</a></td>
               <td>&raquo; <a target="_blank" href="http://www.abetokichaw.com/"> Abe Tokichaw</a> </td>
               <td>&raquo; <a target="_blank" href="http://www.aigaforum.com"> Aigaforum</a></td>
               <td> &raquo; &raquo; &raquo; &raquo; &raquo;&raquo; </td>
            </tr>
            <tr>
               <td>&raquo; <a target="_blank" href="http://www.maledatimes.com/"> Maledatimes</a> </td>
               <td>&raquo; <a target="_blank" href="http://www.ethiopianreporter.com"> Reporter</a></td>
               <td>
                  &raquo; 
                  <a target="_blank" href="http://www.ethiodiasporaradio.com">
                     Ethio Diaspora </a>
               </td>
               <td>&raquo; <a target="_blank" href="http://zethiopianewspaper.blogspot.com"> Z'Ethiopia</a></td> 
               <td>&raquo; <a target="_blank" href="http://www.waltainfo.com"> Walta </a></td>
               <td><a href="http://ethioforum.org/?page_id=5" > &raquo; &raquo; All Links &raquo; &raquo; </a> </td>
            </tr>
         </table>
      </div>
    
     <script type="text/javascript">
	at_attach("src_parent", "src_child", "hover", "y", "pointer");
	</script>
<div class="clear"></div>
	    <div id="container"> 
    
       <div id="main">
    
				


					<div id="post-173780" class="entry post-173780 post type-post status-publish format-standard has-post-thumbnail hentry category-news">

                     
                     						<h1 class="entry_title">

                        	
							Ethiopian Canadian Lawyer Teklemicheal, reflect on Canadian immigration law
						</h1>

<iframe src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2FethioMediaForum%2F&amp;width&amp;layout=standard&amp;action=like&amp;show_faces=false&amp;share=true&amp;height=35&amp;appId=498007506972068" scrolling="no" frameborder="0" style="border:none; overflow:hidden; height:35px;" allowTransparency="true"></iframe>

						 <!--<div class="singlepostmeta"><span style="font-family: Nyala, 'Geez Unicode';font-size:14px;text-align:center;"> ... በፌስቦክ Like ማድረጉንም አይርሱ!  ..መልካም ንባብ፡፡ </span></div>-->		

						<p>Ethiopian Canadian Lawyer Teklemicheal Abebe Sahlemariam reflect on Canadian immigration law. Useful tips for those who has a plan to immigrate to Canada.</p>
<p><iframe width="500" height="281" src="https://www.youtube.com/embed/JtEVIVaPuqE?feature=oembed" frameborder="0" gesture="media" allowfullscreen></iframe></p>
<div class="hupso-share-buttons"><!-- Hupso Share Buttons - http://www.hupso.com/share/ --><a class="hupso_toolbar" href="http://www.hupso.com/share/"><img src="http://static.hupso.com/share/buttons/share-small.png" style="border:0px; padding-top:5px; float:left;" alt="Share Button"/></a><script type="text/javascript">var hupso_services_t=new Array("Twitter","Facebook","Google Plus","Linkedin","Email","Print");var hupso_background_t="#EAF4FF";var hupso_border_t="#66CCFF";var hupso_toolbar_size_t="small";var hupso_twitter_via = "ethiomediaforum";var hupso_image_folder_url = "http://ethioforum.org/wp-content/plugins/hupso-share-buttons-for-twitter-facebook-google/img/services/";var hupso_twitter_via="ethiomediaforum";var hupso_url_t="";var hupso_title_t="Ethiopian Canadian Lawyer Teklemicheal, reflect on Canadian immigration law";</script><script type="text/javascript" src="http://static.hupso.com/share/js/share_toolbar.js"></script><!-- Hupso Share Buttons --></div><div class="clear"></div>


						<div class="singlepostmeta">
Disclaimer: We are not responsible for any losses or damages that may have caused by using our services. EMF declines all responsibility for the contents of the materials stored by users. Each and every user is solely responsible for the posts. <br/>

<!-- BEGIN JS TAG -  ROS 300x250  - DO NOT MODIFY -->

<!-- END TAG -->
</div>

						
							<div class="singlepostmeta">

								<img alt='' src='http://0.gravatar.com/avatar/f6daba0c01b26344dbaee2742d941a96?s=39&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/f6daba0c01b26344dbaee2742d941a96?s=78&amp;d=mm&amp;r=g 2x' class='avatar avatar-39 photo' height='39' width='39' />
								Posted by  <a href="http://ethioforum.org/author/admin-2/" title="Posts by ethioforum" rel="author">ethioforum</a> 

								
								on November 18, 2017. Filed under <a href="http://ethioforum.org/category/news/" rel="category tag">NEWS</a>.

								You can follow any responses to this entry through the <a href="http://ethioforum.org/ethiopian-canadian-lawyer-teklemicheal-reflect-on-canadian-immigration-law/feed/">RSS 2.0</a>.

								
								You can leave a response or trackback to this entry
									

								<div class="clear"></div>

							</div>	

												



					</div><!-- .entry -->



				
				

				
<script language="javascript">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</script>



	
   <div id="comments">

    








	






	






	
	






		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ethiopian-canadian-lawyer-teklemicheal-reflect-on-canadian-immigration-law/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://ethioforum.org/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><table><tr><td width="20"><input type="radio" name="language" value="english" id="english1"></td><td><label for="english1"> <img src="http://ethioforum.org/amharic/uk-flag.gif" /> English</label></td><td width="20"><input type="radio" name="language" value="amharic"  id="amharic1" checked></td><td><label for="amharic1"> <img src="http://ethioforum.org/amharic/Ethiopia_flag.gif"/> ????/Amharic </label></td></tr></table><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" onkeypress="translateOnKeyPress(event,this.form);"  cols="45" rows="8" aria-describedby="form-allowed-tags" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='173780' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e62646aa68" /></p>		<script language="JavaScript" type="text/javascript" src="http://ethioforum.org/wp-content/plugins/cos-html-cache/common.js.php?hash=79e7bbe51bdabe01996780a00cb4adf0"></script>
		<script language="JavaScript" type="text/javascript">
		//<![CDATA[
		var hash = "79e7bbe51bdabe01996780a00cb4adf0";
		var author_cookie = "comment_author_" + hash;
		var email_cookie = "comment_author_email_" + hash;
		var url_cookie = "comment_author_url_" + hash; 
		var adminmail = "media.emf{_}gmail.com";
		var adminurl = "http://ethioforum.org";
		setCommForm();
		//]]>
		</script>
	<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="193"/></p>			</form>
			</div><!-- #respond -->
	






	






</div><!-- #comments -->
				

			</div><!-- #main -->

			

			<div id="sidebar">

				<div class="sidebarinner">
	<div class="sidebar_left">
	<div class="widget">
	<script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x250 -->
<ins class="adsbygoogle"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x250 -->
<ins class="adsbygoogle"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><div id="gab_custom_widget-4" class="widget gab_custom_widget"><div class="widgetinner"><span class="catname"><a href="http://ethioforum.org/category/commentary/">Recent posts</a></span>
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://ethioforum.org/ethiopians-follow-zimbabwe-events-with-mengistu-in-mind/" rel="bookmark" title="Permalink to Ethiopians follow Zimbabwe events with Mengistu in mind" >Ethiopians follow Zimbabwe events with Mengistu in mind</a>
						</h2>
					<p>By Seleshi Tessema ADDIS ABABA (AA) The unfolding political crisis in Zimbabwe this week has intrigued Ethiopians for a specific reason all their own. Indeed, Harare hosts and refuses to extradite the former Ethiopian dictator Mengistu Haile Mariam, who was sentenced to death in absentia, has triggered public attention and&hellip;</p><p class="postmeta"><span class="meta_date">November 18, 2017</span><span class="meta_comment"><a href="http://ethioforum.org/ethiopians-follow-zimbabwe-events-with-mengistu-in-mind/#respond">No Comment</a></span><span class="meta_permalink"><a href="http://ethioforum.org/ethiopians-follow-zimbabwe-events-with-mengistu-in-mind/" title="Permalink to Ethiopians follow Zimbabwe events with Mengistu in mind" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://ethioforum.org/rethinking-gentrification-and-racial-justice-by-dr-maulana-karenga/" rel="bookmark" title="Permalink to Rethinking Gentrification and Racial Justice By Dr. Maulana Karenga" >Rethinking Gentrification and Racial Justice By Dr. Maulana Karenga</a>
						</h2>
					<p>Rethinking Gentrification and Racial Justice: Resisting the Return of the Plantation It is not over-reaching or misreading the signs and tendencies of the time to conceive and confront the ongoing process of what is currently called gentrification as the return of the plantation. Indeed, it fits well within the context&hellip;</p><p class="postmeta"><span class="meta_date">November 12, 2017</span><span class="meta_comment"><a href="http://ethioforum.org/rethinking-gentrification-and-racial-justice-by-dr-maulana-karenga/#comments">1 Comment</a></span><span class="meta_permalink"><a href="http://ethioforum.org/rethinking-gentrification-and-racial-justice-by-dr-maulana-karenga/" title="Permalink to Rethinking Gentrification and Racial Justice By Dr. Maulana Karenga" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://ethioforum.org/the-politics-of-famine-media-activism-and-donor-aid-in-the-horn-by-aregawi-berhe-phd/" rel="bookmark" title="Permalink to The Politics of Famine, Media Activism, and Donor Aid in the Horn By Aregawi Berhe (PhD)" >The Politics of Famine, Media Activism, and Donor Aid in the Horn By Aregawi Berhe (PhD)</a>
						</h2>
					<p>Overview Ethiopia is a geostrategic country in the Horn of Africa region. This ancient country landlocked since 1991 is fractured along many political, ethnic and cultural fault lines and the recurrence of famine in the aftermath of drought and conflict is an ever-present danger. It lies in wait even in&hellip;</p><p class="postmeta"><span class="meta_date">November 9, 2017</span><span class="meta_comment"><a href="http://ethioforum.org/the-politics-of-famine-media-activism-and-donor-aid-in-the-horn-by-aregawi-berhe-phd/#respond">No Comment</a></span><span class="meta_permalink"><a href="http://ethioforum.org/the-politics-of-famine-media-activism-and-donor-aid-in-the-horn-by-aregawi-berhe-phd/" title="Permalink to The Politics of Famine, Media Activism, and Donor Aid in the Horn By Aregawi Berhe (PhD)" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://ethioforum.org/we-are-everywhere-how-ethiopia-became-a-land-of-prying-eyes-nyt/" rel="bookmark" title="Permalink to ‘We Are Everywhere’: How Ethiopia Became a Land of Prying Eyes (NYT)" >‘We Are Everywhere’: How Ethiopia Became a Land of Prying Eyes (NYT)</a>
						</h2>
					<p>By KIMIKO de FREYTAS-TAMURA NOV. 5, 2017 (NYT) FENDIKA, Ethiopia — When he is away from his fields, Takele Alene, a farmer in northern Ethiopia, spends a lot of his time prying into the personal and political affairs of his neighbors. He knows who pays taxes on time, who has&hellip;</p><p class="postmeta"><span class="meta_date">November 6, 2017</span><span class="meta_comment"><a href="http://ethioforum.org/we-are-everywhere-how-ethiopia-became-a-land-of-prying-eyes-nyt/#respond">No Comment</a></span><span class="meta_permalink"><a href="http://ethioforum.org/we-are-everywhere-how-ethiopia-became-a-land-of-prying-eyes-nyt/" title="Permalink to ‘We Are Everywhere’: How Ethiopia Became a Land of Prying Eyes (NYT)" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://ethioforum.org/oromo-amhara-accord-hope-for-ethiopias-future-by-addissu-admas/" rel="bookmark" title="Permalink to Oromo-Amhara Accord: Hope for Ethiopia’s Future  By  Addissu Admas" >Oromo-Amhara Accord: Hope for Ethiopia’s Future  By  Addissu Admas</a>
						</h2>
					<p>&nbsp; The fact that Ethiopia is presently ruled by representatives of a minority nationality may puzzle, surprise, or aggrieve any reasonable Ethiopian. But a closer look and attentive examination of the events of the past 26 years would reveal that the situation we are living and enduring today, and what&hellip;</p><p class="postmeta"><span class="meta_date">November 6, 2017</span><span class="meta_comment"><a href="http://ethioforum.org/oromo-amhara-accord-hope-for-ethiopias-future-by-addissu-admas/#respond">No Comment</a></span><span class="meta_permalink"><a href="http://ethioforum.org/oromo-amhara-accord-hope-for-ethiopias-future-by-addissu-admas/" title="Permalink to Oromo-Amhara Accord: Hope for Ethiopia’s Future  By  Addissu Admas" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost lastpost">

											<h2 class="posttitle">
							<a href="http://ethioforum.org/28-killed-in-rare-protests-in-eritrea-report/" rel="bookmark" title="Permalink to 28 killed in rare protests in Eritrea &#8211; report" >28 killed in rare protests in Eritrea &#8211; report</a>
						</h2>
					<p>Several people have reportedly been killed and dozens arrested in Eritrea&#8217;s capital. Protests are rare in Eritrea, home to one of the world&#8217;s most repressive regimes. At least 28 people have been killed and dozens more arrested in rare protests that rocked the Eritrean capital, a member of an opposition&hellip;</p><p class="postmeta"><span class="meta_date">November 2, 2017</span><span class="meta_comment"><a href="http://ethioforum.org/28-killed-in-rare-protests-in-eritrea-report/#respond">No Comment</a></span><span class="meta_permalink"><a href="http://ethioforum.org/28-killed-in-rare-protests-in-eritrea-report/" title="Permalink to 28 killed in rare protests in Eritrea &#8211; report" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
                </div></div>
	</div><!-- .sidebar_left -->
	
	<div class="sidebar_right">
<!-- BEGIN JS TAG -  ROS 160x600  DO NOT MODIFY -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 160-600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-8421858419192011"
     data-ad-slot="2200844028"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<!-- END TAG -->
		<script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- emf skyscraper -->
<ins class="adsbygoogle" style="width:120px;height:600px"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>	</div><!-- .sidebar_right -->
	<div class="clear"></div>
</div><!-- .sidebarinner -->
			</div><!-- #Sidebar -->	

			<div class="clear"></div>

	</div><!-- #Container -->



<!--cos-html-cache-safe-tag-->




